Labor und Sonderzeichen

Mehr
8 Monate 11 Stunden her #1061 von AlexHoe
AlexHoe antwortete auf Labor und Sonderzeichen
Hallo Herr Klawitter,

das mit den Laborwerten bzw. den Normwerten im Laborbrief funktioniert jetzt.

Prima!!

VIELEN DANK!!!

Hölzel

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
8 Monate 4 Tage her #1058 von klawitter
klawitter antwortete auf Labor und Sonderzeichen
Hallo zusammen,

das Geheimnis lag in den Leerzeichen - vorne eines zu viel - hinten eines zu wenig.
Beim Einlesen von HTML nach Word wird die Sequenz " <xx" (erstes Zeichen ist ein Leerzeichen) als Steuerzeichen interpretiert und, da nicht definiert, eben weg gelassen. " < xx" funktioniert und ebenso "<xx" (also ohne führendes Leerzeichen). Letzteres ist auch der Lösungsweg.
Im Browser wird spannenderweise jeder Fall korrekt angezeigt.
Langer Rede... ab 3.9.0.31 kommt alles wieder richtig rüber.

viele Grüße
Wolfgang Klawitter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
8 Monate 1 Woche her #1056 von klawitter
klawitter antwortete auf Labor und Sonderzeichen
Hallo zusammen,

ich kümmere mich nächste Woche darum - danke für die Vorarbeiten!! (ich hatte mit dem Import bzw. Export von PDF-Dateien zu kämpfen, so dass sich alles etwas verschoben hat)

viele Grüße

Wolfgang Klawitter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
8 Monate 1 Woche her #1055 von schwieder
schwieder antwortete auf Labor und Sonderzeichen
Hallo Herr Bettker-Cuza,

was ich bis jetzt im Vergleich ihrer mit einer LDT-Datei von meinem Labor finden konnte:
  • Gleiche LDT1014.01 Dateiversion.
  • Das "<"-Zeichen hat den gleichen Hexadezimalwert 3C wie bei mir. Dies ist ein Zeichen, das in der LDT-Datensatzbeschreibung als zulässiges Zeichen enthalten ist, sollte also prinzipiell kein Problem sein.
Einziger Unterschied bei mir:
Nach dem "<" fügt mein Labor noch ein Leerzeichen (Hexadezimalwert 20) vor dem Zahlenwert ein.
Vieleicht kann Wolfgang ja bei Arbene bei dem Feld Normalwert-Text (Feldkennung 8460) einstellen, dass der Import trotzdem funktioniert.

MfG
J. Schwieder

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
8 Monate 2 Wochen her - 8 Monate 2 Wochen her #1051 von rorro
rorro antwortete auf Labor und Sonderzeichen
Hallo Herr Schwieder,

wenn's an meinem Labor liegt, habe ich auch ein Problem, da sie das wegen mir bestimmt nicht ändern werden.

Ich habe mal das letzte Labor (war nur einer) anonymisiert drangehangen, die Normwerte sind aller unter der LDT-Ziffer 01x8460 hinterlegt.

Vielleicht können Sie mir da helfen. Vielen Dank!

Dateianhang:

Dateiname: Labortest.txt
Dateigröße:3 KB
Anhänge:
Letzte Änderung: 8 Monate 2 Wochen her von rorro.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
8 Monate 2 Wochen her #1042 von schwieder
schwieder antwortete auf Labor und Sonderzeichen
Hallo Herr Bettker-Cuza,

seltsam, bei den von "meinem" Labor gelieferten LDT-Daten sind auch Zeichen wie "<" und ">" in den Normwerten enthalten und diese werden von Arbene einwandfrei importiert und auch wieder ausgegeben.
Hier ein Beispiel eines über #werte# erzeugten Laborberichts:

Auch in Arbene sind die Zeichen richtig importiert.


Vieleicht liegt es ja an "ihrem" Labor. Könnten Sie mal eine ihrer LDT-Dateien, die diese Sonderzeichen enthält, anonymisieren, also mit einem Texteditor die Namen und Vornamen durch Pseudonyme ersetzen, und dann als Anhang posten?

MfG
J. Schwieder
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.111 Sekunden
Powered by Kunena Forum